Linux Rsinglish Installation

NOTE: I recommend you not to use ibus, use fcitx instead

Ubuntu Oneiric users please use scim instead of ibus, there’s a bug in ibus-m17n which is not fixed as of writing fixed read here. You may go on running the rs.sh file as said below, make sure you are using the fixed version. Ubuntu 12.04 doesn’t have such a problem, you are advised to upgrade, with 12.04 you do not need to run rs.sh, si-singlish.mim is shipped by default thanks to m17n-lib team.

Ubuntu users goto the terminal and type this and press enter,

sudo apt-get install ibus-m17n zenity

Debian(or some Debian derivatives) users goto the terminal and type this and press enter,

su root -c "apt-get install ibus-m17n zenity"

Red hat or Red Hat derivatives(Fedora, SUSE..etc) users type this in terminal and press enter,

su root -c "yum install ibus-m17n zenity"

Other distro users: get ibus-m17n package and zenity package installed some how.

Now download this zip file. Extract rs.sh and run it by going to the extracted path and typing,

sh rs.sh

E.g. : If you extracted to the Desktop,

cd ~/Desktop
sh rs.sh

* Zenity is not mandatory but its needed to display messages from the script as GUI messages.

Advertisements

28 thoughts on “Linux Rsinglish Installation

  1. mama scim run kala terminal eken eth ita passe scim setup eka open kala eth itapasse karanna deyak nane 😦 can you explain the procedure little bit 🙂

    Reply
  2. Hi madura,
    I am using Fedora14 o/s..and I hv installed below package as u hv mentioned too.

    yum install ibus-m17n zenity

    then I have tried installing rsinglish using ur shell script(rs.sh) most of the things gone okay.. but at last end i a got error saying like below..

    rs.sh: line 18: im-switch: command not found

    whats the error as u think? thanks this is really works well in Windows..I am lovin using this Application.
    Thanks and Regards,
    Harsha

    Reply
  3. just installed this on oneric (ubuntu 11.10). No need to jump through all those hoops. It works just fine in ibus. No need to patch anything either.

    Reply
  4.  hi.. I’m using 12.04 beta2. I executed “sudo apt-get install ibus-m17n zenity” . What am I supposed to do now. ? how to get start it? thanks..!

    Reply
  5.  නෙවර් මයින්ඩ්. අයි ෆිගර් ඉට් අවුට්.. 🙂 බොහොම ස්තුතියි..!!!

    Reply
    • Great, you do not need to install singlish,mim it comes in the default ibus-m17n package just installing ibus and running it is enough

      Reply
  6. Pingback: තමන්ට කැමති විදියට සිංහලෙන් ලියමු. :) | ෴ Help World ෴

    • the link was broken, I fixed it. ibus is not that much recommended now, I’d rather say fcitx does a better job plus newer m17n packages the mim by themselves so rsinglish comes by default

      Reply
  7. Pingback: Install RSinglish-a real time sinhala unicode converter on linux | problem solved

  8. පට්ට සමහර එවා නම් ගහන්න ටිකක් අමාරුයි. පුරුදු වෙනකොට ගොඩ යයි. මම පාවිච්චි කරන්නෙ උබන්ටු 14.04. ඔබට බොහොම ස්තුතියි.

    Reply

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s